Shader error with CubeMapMaterial, repeatable in example file - SOLVED

Tags: #<Tag:0x00007f7035523be8>

Hi there,

I just opened up a project I’m working on to find a shader error with CubeMapMaterial. I thought it was something I was doing incorrectly, but also seeing it show up in the editor for the CubeMapMaterial example file (https://cables.gl/edit/u5y0Z5). Strangely the texturing seems to be fine when I run the file outside of the editor.

Below is some info from the error message.

Shader error errorshader

ERROR: 0:59: 'textureLod' : no matching overloaded function found
ERROR: 0:59: 'return' : function return is not matching type:
The line with the error reads: 
59:         return textureLod(tex,sampleUV,lod);

which browser are you using ?

Google Chrome – Version 81.0.4044.138 (Official Build) (64-bit)
on Windows 10

ok, I figured it out – switched on force to webgl v1 earlier and didn’t realize this setting carries between sessions. Thanks for reply!

Best,

Julian

Hey julianstein,

Thanks for pointing that out. With the next update CubeMapMaterial will be compatible with WebGL1!

Regards,

Simo

1 Like