Opacity in Texture - SOLVED

Tags: #<Tag:0x00007f703671cd18>

Hi Cables,

I try to follow the tutorial: https://www.youtube.com/watch?v=IavCAfgXcqc&list=PLYimpE2xWgBveaPOiV_2_42kZEl_1ExB0&index=6.
However, when it came to the part of textureOpacity, it always has one face which is not exactly transparent. I am not sure if this is my own problem. Below is the image of my patch:

Do you know why? Is it because of the browser (I tried others, but still remain the same)?
Thank you for your answer in advance.

Best,
Gary

Hi Archgary,
I think the default texture isn’t outputting absolute values that you can use for transparency.
Here’s an example patch showing it working correctly.
Make sure to enable “discard transparent pixels” on the basic material op.

Thanks a lot for the answer and the example! It did work!
Then, I am curious what is the “Opacity TextCoords Transform” for?

Thanks for your answer in advance! Appreciate it.

Best,
Gary

“Opacity TextCoords Transform” controls if the opacity mask has the repeat/offset options applied

Thanks for your answer. It is clear now! Appreciate it~