Error on cables wpplugin

hey cablers,

Previously I use the plugin on infinityfree it works perfect. then I use different hosting which is WPEasy from namecheap, there’s always error everytime I pur my patch on the page.
I received an email with this error message: An error of type E_PARSE was caused in line 40 of the file /var/www/wptbox/wp-content/plugins/cables-wpplugin/templates/_partials/patch.php. Error message: syntax error, unexpected ‘endif’ (T_ENDIF), expecting end of file

these are the things that I use:
WordPress version 5.8
Current theme: OceanWP (version 3.0.6)
Current plugin: cables.gl Wordpress (version 0.12.2)
PHP version 7.4.12.

Cheers and have a great day everyone!

hey,

just tried a few patches in wordpress 5.8, php 7.5.23 (as well as 8.0) and plugin version 0.12.2 and do not have these problems. is this reproducible somehow (only on certain placement (header, footer, background), only with certain patches (feel free to add me as a collaborator (username: stephan), only with that theme active, only on that hoster, …)?

the error sounds like your patch-export somehow is messing up the php page…which would be interesting…

looking forward to help you getting this working again with a bit more information. send a direct message or contact me on discord (steam) if you cannot share patches or urls. thanks!

best,
stephan/steam

hey,

thanks for the reply. I have added you as the collaborator. I used everything the same, same plugins, same theme. only the webhosters are different. thanks man!

cheers!

hey,

tried this with your patch, works fine for me. i’ve attached my settings but i tried to match yours as much as possible. i also do not understand how a “parse error” would be hoster-related but i guess something is weird with your new hoster…let me know if i can investigate more. sorry…

best,
stephan/steam


Bildschirmfoto 2021-09-10 um 10.02.15

hey stephan,

I found something. for the patch to be set as background it’s working. but when I tried to make it as hero image it’s not working. I hope you can investigate this. Thanks!

hey,

sorry, didnt get around to answer this. tried any integration and stuff works fine locally (for spaces that the theme provides). is there any way i can access the page/see some logfiles or maybe us doing this together somehow? i think this somehow is your new hoster…would be interesting to know why, though.

best,
stephan/steam