CustomShader2 uniforms don't update - SOLVED

I’ve some Number ops feeding uniforms of a CustomShader2 op. When updating the Number in the UI, the uniform does not update the shader, and the rendered output does not change.

I haven’t been able to successfully create an isolated test case for this, but you can see it happen in this patch: https://cables.gl/edit/MVox-M

When changing the SCALE and OFFSET, neither ‘SDF to Texture’ or ‘Raymarch’ update, however when you edit and save their fragment code, the new values are picked up.

For example, try changing ‘SCALE X’ to 3, nothing changes. If you then touch both shaders (make a whitespace change to their fragment code), you’ll see the bounding box of the sphere shrink. I’d expect to see this change immediately on changing the value.

Strangely this problem does not happen for the SUBDIVISIONS ops.

hey thanks for those bug reports!

interesting, this only seemed to happen with big shaders with lots of uniforms.

i fixed it. let me know if this happens again!

Thank you for fixing it so quickly :slight_smile: I’ve found another issue now, I’ll raise a new ticket.