Can't export assets

Tags: #<Tag:0x00007f7036057e38>

Hello! I want to export the path, but I can’t export uploaded images. Using lib’s images can export.

Hi Lozzer,

Could you please post an example patch so I can try to recreate this ?

Thank you andro!!! Here is the patch’s URL, Thans!
https://cables.gl/p/5c2cb4e9dd388e05fb6bdd4b?s=gkPnCO50ChiP6uXU

Hi Lozzer,
I’ll assume your exporting this patch so you can run it on your own server.
You need to create a assets folder inside of the exported cables patch and then add your images there.
Using ParseArray in this way means that cables can’t know where those textures are.
Can you get back on this and tell us if it then works ?
Thanks.

what andro means is, put your absolute urls into the parsearray

like:

https://myserver.com/pics/1.jpg,
https://myserver.com/pics/2.jpg,
https://myserver.com/pics/3.jpg

(cables can not export your files because there are just text in an array, it can only export files that are given via a file input (for example texture op)

That’s it! Thank you andro! Only I create a new texture op for each image, it can be exported. But if I have lot of image? I tried the method pandur provided, I put absolute urls into the parsearray, exported without files, it can be work.

Thans! I tried the method you provide, exported without files, it can be work.

great! let us know when you launch the website :slight_smile:

OK! Thank you for your answer.

So I think I’m encountering a similar issue. I have a comp which uses a ParseArray, parsing a list of urls linking to media.

Sorry If I sound silly I’m new to this. I’ve exported the composition and uploaded that to my ftp. (I’m using FileZilla). In the assets folder I’ve added all my content that was missing from the export from cables.

I guess I now need to relink these. so do I have to go into my comp and update the urls to the ones I’ve uploaded so something like ftp://adminftp…cables_project/assets/file.jpg? and after do I have to re-export it once it’s saved with the new urls? seems like a bit of a catch 22 unless I’m missing something?

or would you recommend another route for sites that aren’t running localy?

sorry i don’t understand.

have you tried using the developer tools of your browser and look at the URL that is loaded ?

or can you send the URL of your uploaded patch on your server ?

So heres my prototype composition, you can use the left and right arrow keys to cycle through different content. only 2 parts at the moment.

Exporting the project it says it’s missing some files which is expected as these are being referenced.

My test websites www.marioepsley.com, if you click on the only link it should open up the composition. You’ll have to track out using the trackpad as it’s very zoomed in. It has orbit controls so if you look around you’ll see the parts that were included in the export.

I’ve dropped into the assets folder a few clips that weren’t downloaded to test. Heres the url for one of them:

ftp://adminftp…/assets/3.jpg

I went back into my project and replaced the text which is being parsed to read these new destinations but they’re still not appearing and I’m not sure why, or if theres a better way to do this.

Thanks.

Any help or advice would be greatly appreciated, I’d love to find a way to get this working correctly online.

hi, as you can see in the developer tools the server returns a 404

the patch tries to load the image from e.g: http://www.marioepsley.com/assets/5ce6bfa280314e3dc43f786f/Screenshot_2019-05-23_at_20.17.45.jpg

do you know the real adress where is is accessible ?

Thanks Pandur,

I think I understand now, I need the actual http link to the file as opposed to the ftp link. Going to see if I can get this working. Will report back :wink:

I feel like I’m getting closer :slight_smile:

Here is an actual link to a file I’m calling, I’m assuming it’s what I should be using.
(http://www.marioepsley.com/cables_texturefromarray033/assets/2.jpg)

I had a go at trying this (updating the text field) but I now get a red box saying it could not load the texture.

Any ideas?

sorry did not see this. now it’s a 404

sadly the web is a horror of security rules these days.
see: https://developer.mozilla.org/en-US/docs/Web/HTTP/CORS

maybe can you describe what you are trying to achieve in general ?