3D objects not showing up

Tags: #<Tag:0x00007f7037980450> #<Tag:0x00007f7037980298>

I’m having problems with viewing my patch. I’ve made a patch using a simple 3d object which worked perfectly in the preview window, but after saving the patch nothing shows up anymore. Any idea what causes this and how I can fix it?

forgot to connect it to the trigger of a parent op?
to prevent it from displaying it centerd and only instanced
you can use trigger once op or just uncheck the draw option in mesh3d op

As far as I know everything is connected the right way. It worked correctly before saving so it I think it’s not about the ops but I’m not sure

it needs to trigger the mesh3d op at least once in order to load it, thats why it works before saving/reloading :slight_smile: i set it up like this

Ah thanks!
so if I understand it correctly it needs to trigger the 3dmesh op before the mesh instancer knows what to use so to speak?

hi,

it is a bug: mesh should output null or an empty geometry when not being triggered.

mesh3d will be deprecated at one point, we are concetrating on the gltf file format