3D animations (fbx format) converted in glt format doesn't render

Tags: #<Tag:0x00007f703488da00> #<Tag:0x00007f703488d938> #<Tag:0x00007f703488d870>

So I have this problem, I made this 3D animation in Cinema 4D that I then converted from fbx to gltf to make it work in cable. But when I am trying to put the gtlf file in cable it doesn’t render.
Here is an exemple : https://cables.gl/edit/5f5a24eec4a3c2046670d413
I just took this basic patch to experiment with MapRange and then I just tried to change the original cube with my 3D animation but as you can see it doesn’t work.
I hope it can be resolve.
Thank you for reading me and let me know if you see anything I missed! :slight_smile:

Your example link is broken.

I mention a (very very non-optimal) workaround that uses C4D in this thread, however, it could be you are facing the same issue I’ve experienced with cables and rigged animations in GLTF (which for now isn’t supported).

Hi @gleam
Mmmmm weird it works for me though but yeah I just read your exchange and it’s exactly the same issue I am running into! However I don’t have blender and in my case I am just looking to export an animated shape without any texture, will I need to use blender for that? or can just export from Cinema 4D in fbx format and then convert it into glb?
Thank you for your reply it’s already a big help

It should work just fine without blender. The trick is the alembic cache, I don’t know C4D at all, but I assume it’s trivial to export from C4D too. You might not even need to do a fbx export, just transfer the baked PLA from the alembic cache to whatever mesh you have already present in C4d.

Do please note that this inflates the filesize of the GLTF export manifold and can be a horribly inefficient solution, so take care there.

Ok, thanks @gleam , will try to find a good way out then.
Did you succed in importing your animation in the end?

Yes, it does import & work as expected, but I’d only use it for very simple animations/meshes (it quickly gets way too big with regards to file size otherwise).

1 Like

Hi @gleam,

It worked! Thank you so much for your help and you were right the only thing to do is to right click on the object you want to export and to look for Comfort in Alembic + Delete then export it as a FBX and then convert it through a website in gtlf and you just have to put a timer on the GltfScene patch in Cable and there you go the animation is working!
Life is great!